Forum Discussion

bsdpruegelknabe's avatar
Icon for Nimbostratus rankNimbostratus
May 23, 2011

VirtualServer::set_connection_mirror_state doesnt work since




today I stumbled upon a strange error. Every time I call VirtualServer::set_connection_mirror_state it sets the mirror connection to true. Even if I set, with the API-call, it to disable!


This is what i see in the log files:




debug iControlPortal.cgi[16315]: LocalLB:+++++++++++++++++++++++++++++++++++++


debug iControlPortal.cgi[16315]: LocalLB:VirtualServer::set_connection_mirror_state ( ) called by user "admin"


debug iControlPortal.cgi[16315]: LocalLB: Virtual servers:


debug iControlPortal.cgi[16315]: LocalLB: [0] vs_mirrortest, State: Disable


debug iControlPortal.cgi[16315]: LocalLB:-------------------------------------





So, mirror connections should be disabled, right? But, if I look at the VS at the webfrontend (or with the API-call "get_connection_mirror_state") it is enabled! :-o


This change happend after upgrade to V10.X.X



Can anyone acknowlege this error? Does a workaround/bugfix exists?







3 Replies

  • I just tested this on my dev build of v11 and it behaves the same way, but then again my system isn't setup in a redundant configuration so that may effect the setting. Since the trace shows the correct parameters in and you aren't getting the desired result, this is likely a case to get product support involved as it looks like the is an issue with the backend implementation of this method.





  • This bug was reported previously:





  • Ah, thank you both for confirmation. So I'm not just to dumb to use the API. ;-)


    I hope they fix this with an hotfix also and not just with a new Release. :-)