Forum Discussion

Anthony_Ventimi's avatar
Icon for Nimbostratus rankNimbostratus
Jun 20, 2012

OWA 2010 Freezes when trying to access a shared mailbox




Currently we have two F5 BIG IP 3900's deployed for our Exchange 2010 environment. We are noticing when users are using the VIP address to access another shared mailbox OWA freezes right after login, the only way to get out is to close the browser (This does NOT happen when they user OWA-Lite)



For instance users put in the following link:






The OWA login pages displays normally once after the user logs in the page freezes and they're stuck.



If they access the shared mailbox directly via a single CAS server in the array, the page loads fine, which is pushing me in the direction of a configuration issue with the F5 device.






This works just fine.. I did some searching around on the forums and found this article:



I removed "Keep Accept-Encoding" from the HTTP profile but the issue still occurs, if anyone has some thoughts on this issue it would be greatly appreciated.







5 Replies

  • mikeshimkus_111's avatar
    Historic F5 Account
    Hi Anthony, this only happens when opening a shared mailbox, not the user's own mailbox? I just tried to replicate this but was unable to. Does it still happen if you remove all but one CAS server from the LTM pool?



    Which version of BIG-IP are you running? Did you deploy using an iApp template?



    Is it possible to monitor the traffic with a utility such as HTTPWatch or Fiddler, to see which request it is getting hung up on?




  • Hey Mike,



    So far it's mainly with a shared mailbox; I didn't try removing any CAS servers from the LTM pool.. I can try and let you know.



    Were running the follow build: BIG-IP 10.2.4 Build 577.0 Final



    Were using the following profile: microsoft_exchange_2010_https_http-lan-optimized-caching_shared_http



    And yes we used a iApp template for Exchange


  • mikeshimkus_111's avatar
    Historic F5 Account
    OK. Also, make sure that you are using the latest version of the deployment guide, located here:





    The version you want is 4.0, dated 5-22-2012.
  • I have done serveral F5 LTM and Exchange 2010 configurations. Same problem everywhere with OWA freeze. Solved the problem by removing the Web Acceleration Profile that iApp creates on the VS with OWA.


  • Bjarne is correct, try disabling Web Acceleration. I'm running a pair of 3900s on 11.1 with iApp template "f5.microsoft_exchange_2010_cas.2012_06_08". Here's what I had to do with the assistance of support:



    First, disable the Strict Updates option under (iApp >> Application Services >> Properties >> Advanced).



    Then, when you try to go into the individual virtual servers and click "none" on the web acceleration profile you will receive the following error:



    "01070394:3: CACHE::disable in rule (/Common/ requires an associated WEBACCELERATION profile on the virtual server (/Common/"



    The resolve this error, do the following:



    Navigate to Local Traffic >> iRules and click on the rule named "iApp_Exchange_2010_combined_vs_persist_iRule" and comment out the three lines that have CACHE::disable listed. Just put a sign in front of them, and then click Update at the bottom.



    I hope this helps someone.