Forum Discussion

jmcalister_2791's avatar
Icon for Nimbostratus rankNimbostratus
Jul 15, 2016

Issue setting route domain parent with PowerShell / iControl

Good morning,

I am attempting to script the configuration of an existing route domain. I am able to set the description, set strict isolation, and other settings, but when I attempt to set the parent ID I am running into some strange behavior.

I am attempting to configure a route domain with an ID of 6 to have a parent that has an ID of 501. If I run the script below I receive the following error:

error_string : 01070734:3: Configuration error: Invalid route domain modification. A domain id change from 4 to 6 is not supported"

$objiControlBigIP1 = New-Object iControl.Interfaces
$objiControlBigIP1.initialize(IPADDRESS, PORT, USERNAME, PASSWORD)

But when I look at the system audit list it appears to have taken the change, but the change is never made in the console:

client Unknown, user admin - transaction 1665299-3 - object 0 - modify { route_domain { route_domain_id 6 route_domain_parent_name "/Common/PublicInternet" } } [Status=Command OK]:

If I run the script with any number other than 501 it runs without an error, logs in the audit log with a success, but still does not make the change.

Thank you for any information or assistance!

No RepliesBe the first to reply